如何在Android Studio v 1.1 / 1.2中呈现问题?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (17)

当我添加android.support.v7.widget.Toolbar或其他android.support.v7.widget.*有渲染问题。

但支持库是最新的。而且我正确地遵守了依赖。我可以将它们导入MainActivity.java。

提问于
用户回答回答于

我不知道这是否会有所帮助,但我创建了一个测试项目并获取此错误。试图修改项目结构并找到缺失的班级并没有帮助。

生成失败,出现以下错误:

***渲染问题

以下类无法找到 android.support.v7.internal.widget .ActionBarOverlayLayout ***

显然这不是最终的解决方案,但是将设计视图中的主题从基本“项目主题”更改为任何其他内容都可以构建。

用户回答回答于

更新:显然,他们已经修复了最终Android Studio 1.3版本中的这个错误(根据用户在问题跟踪器中报告此问题所解决的问题:https//issuetracker.google.com/issues/37043358)。

这是Android Studio build 1.1以来的一个已知错误,它仍然存在于AS 1.2和1.3 beta版本中。将预览的API级别从22更改为21可以解决大多数人的问题。在等待修复时,你可以尝试一下。

扫码关注云+社区