如何PIP安装一个最小和最大版本范围的软件包?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (22)

我想知道是否有任何方法可以告诉pip,特别是在需求文件中,安装包含最低版本(pip install package>=0.2)和最高版本(永远不会安装)的包(理论api:)pip install package<0.3

我问,因为我正在使用正在积极开发的第三方库。我希望我的pip要求文件指定它应该始终安装0.5.x分支的最新次要版本,但我不希望pip尝试安装任何较新的主要版本(如0.6.x),因为API是不同的。这很重要,因为即使0.6.x分支可用,开发人员仍然会向0.5.x分支发布补丁和错误修正,因此我不想package=0.5.9在我的需求文件中使用静态行。

有没有办法做到这一点?

提问于
用户回答回答于

你可以做:

$ pip install "package>=0.2,<0.3"

并且pip会寻找最佳匹配,假设版本至少为0.2,并且小于0.3。

扫码关注云+社区