如何在eclipse aptana插件中的rails上调试ruby?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (17)

我试图找出这个eclipse aptana插件。当我尝试如下调试我的项目时:

它会抛出这个错误:

Unable to find 'rdebug-ide' binary script. May need to install 'ruby-debug-ide' gem, or may need to add your gem executable directory to your PATH (check location via 'gem environment').

这是gem environment

RubyGems Environment:
  - RUBYGEMS VERSION: 1.5.2
  - RUBY VERSION: 1.9.2 (2011-02-18 patchlevel 180) [i386-mingw32]
  - INSTALLATION DIRECTORY: C:/Ruby192/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: C:/Ruby192/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/Ruby192/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - C:/Ruby192/lib/ruby/gems/1.9.1
     - C:/Users/Lol/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

服务器可以启动,我可以去localhost:3000并加载。但我不明白这个错误或如何开始调试。任何想法有什么不对?

提问于
用户回答回答于

从命令行发出以下命令:

gem install ruby-debug-ide

错误消息是说你没有安装这个gem。似乎Aptana在激活某些功能之前没有检查是否安装了哪些gem。

如果你不知道什么是gem,可以把它想象成一个安装在系统范围内的插件。

用户回答回答于

扫码关注云+社区