如何在El Capitan(OS X 10.11)上设置需要遗留Java的应用程序?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (33)

我有一个干净的El Capitan安装。我的Macbook Air上安装了PHPStorm。当我尝试运行该应用程序时,出现一个错误,指出PHP风暴无法打开,因为它需要使用旧版Java SE 6.我附加了下面错误的图像。

当我安装Yosemite时,我遇到了同样的问题,但是我能够从Apple的网站上安装遗留Java修补程序(Java for OS X 2014-001)。当我尝试安装相同的Java修复程序时,出现以下错误: Java for OS X can't be installed on this disk. A newer version of this package is already installed

提问于
用户回答回答于
用户回答回答于

扫码关注云+社区