如何在GEM中指定最低的Ruby版本?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (21)

我正在为一个新版本的gem编写一个gemspec,现在需要Ruby 1.9。以前的版本的宝石适用于Ruby 1.8,但现在需要1.9。有没有办法导致这个版本的gem的gem安装失败,并给用户试图在Ruby 1.8上安装它的警告?

提问于
用户回答回答于

RubyGems文档:

# This gem will work with 1.8.6 or greater...
spec.required_ruby_version = '>= 1.8.6'

# Only with ruby 2.0.x
spec.required_ruby_version = '~> 2.0'
用户回答回答于

扫码关注云+社区