首页
学习
活动
专区
圈层
工具
发布

Linux SSH远程连接端口修改

Linux SSH端口修改及故障排除指南 ️ 摘要 在运维过程中,更改SSH端口是一项常见的安全措施,但有时会遇到一些问题,例如SELinux的拒绝或防火墙设置错误。...vim /etc/ssh/sshd_config 为了防止编辑错误,建议在编辑之前备份配置文件: cp /etc/ssh/sshd_config /etc/ssh/sshd_config.bak 修改端口号为你想要使用的新端口号...我们进入需要输入 i 进入编辑状态,如上图修改好之后;按 esc 后输入 :wq 即可保存退出; 保存文件并退出编辑器。...查看开放端口 您可以使用以下命令查看当前开放的端口: firewall-cmd --list-ports 添加新端口 假设您的新SSH端口为2022,您可以使用以下命令添加新端口: sudo firewall-cmd...参考资料 Linux防火墙配置指南 SELinux官方文档 SSH配置文件详解 希望这篇文章对您有所帮助,如果有任何疑问或建议,欢迎留言交流!

11.4K10
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Linux学习笔记之Linux修改或增加ssh端口

    SSH的数据是经过压缩的,所以可以加快传输的速度 2.修改或者添加SSH端口 1. 首先查看一下当前linux是否已经安装SSH软件包,使用 rpm -qa|grep ssh ?  ...,例如 Port 3333; 如果你想另外保留原来的22端口不变,把Port 22前面的#去掉即可,以后你可以通过3333和22两个端口SSH到你的主机。...修改保存后,重启SSH服务(如下是7版本以下的命令,如果是7版本以上的系统,相关命令请自行百度): /etc/init.d/sshd restart 或者 service sshd restart 4...为了保持这个端口,需要关闭防火墙并加入这个端口 CentOS 7、RedHat 7 之后的 Linux 发行版防火墙开启和关闭( firewall ): systemctl stop firewalld.service...:端口/通讯协议 # --permanent 永久生效,没有此参数重启后失效

    2.9K50

    LINUX下如何修改IPTABLES开启80端口

    inux下如何修改iptables开启80端口 最近在做本地服务器的环境,发现网站localhost能正常访问,用ip访问就访问不了,经常使用CentOS的朋友,可能会遇到和我一样的问题。...开启了防火墙导致80端口无法访问,刚开始学习centos的朋友可以参考下。 经常使用CentOS的朋友,可能会遇到和我一样的问题。...最近在Linux CentOS防火墙下安装配置 ORACLE   数据库的时候,总显示因为网络端口而导致的EM安装失败,遂打算先关闭一下CentOS防火墙。...这样重启计算机后,CentOS防火墙默认已经开放了80和22端口  简介:CentOS是Linux家族的一个分支。 ...这样重启计算机后,CentOS防火墙默认已经开放了80和22端口。

    7.8K30

    vncserver端口的修改

    http://hi.baidu.com/wxf966/blog/item/301c95f4920aabfe7709d71c.html vnc的默认端口是5901,这个说法是不对的。...vnc并不是只有一个端口 先看看这个配置  VNCSERVERS="1:oracle 2:root"  VNCSERVERARGS[1]="-geometry 800x600 -nolisten tcp...这里就配置了2个桌面,一个桌面号是1, 一个是2. vncserver在调用的时候,会根据你的配置来启用server端的监听端口, 从5900开始,加上你的桌面号,比如这里的oracle就是5901,root...就是5902 这里可以修改桌面号来确定端口,如桌面好设为10000,那么端口就是15900.还可以修改vncserver启动命令来修改5900+为15900+ 从vncserver这个启动命令开始吧, ...vnc服务,如果有连接的客户端,使用vncserver -kill :桌面号退出,然后替换118和274行的5900为15900,然后重启服务 # service vncserver restart 查看端口

    9.3K31

    修改ssh默认端口

    修改ssh默认端口 1 . 登录服务器,打开sshd_config文件 [root@centos ~]# vim /etc/ssh/sshd_config ---- 2 ....找到#Port 22,默认是注释掉的,先把前面的#号去掉,再插入一行设置成你想要的端口号,注意不要跟现有端口号重复 .........SSH默认监听端口是22,如果你不强制说明别的端口,”Port 22”注不注释都是开放22访问端口。上面我保留了22端口,防止之后因为各种权限和配置问题,导致连22端口都不能访问了,那就尴尬了。...Ok,继续,我增加了10022端口,大家修改端口时候最好挑10000~65535之间的端口号,10000以下容易被系统或一些特殊软件占用,或是以后新应用准备占用该端口的时候,却被你先占用了,导致软件无法运行...使用ssh命令进行远程登录时,实际上可以不使用-p选项显示指明端口,我们可以通过配置文件的方式来设置ssh命令默认端口。

    39.5K42

    Linux 修改SSH 默认端口 22,防止被破解密码

    Linux/Unix 系统,很多人使用SSH + 密码来登陆服务器,默认 22端口,这样会有被暴力破解密码的危险(除非密码足够复杂且长度很长),因此最好修改SSH默认的22端口为其它随机端口号。...这样做的好处,就是因为如果新修改的端口号无法连接,可以仍然使用默认的22端口登录,否则,可能无法连接或出现一些问题后会导致你无法通过SSH连接到服务器,那就惨了。...本文原文来自米扑博客:Linux 修改SSH 默认端口 22,防止被破解密码 本文实例的系统环境 阿里云 CentOS 7.4 一、修改配置文件 1....修改配置文件 /etc/ssh/sshd_config vim /etc/ssh/sshd_config 修改 #Port 22 #ListenAddress 0.0.0.0 #ListenAddress...端口,就是为了来替换默认端口22的,大家在修改端口时候最好挑10000~65535之间的端口号,10000以下容易被系统或一些特殊软件占用,或是以后新安装的应用可能占用该端口,所以10000以下的端口号都不要使用

    9.4K52
    领券