腾讯云
开发者社区
文档
建议反馈
控制台
登录/注册
首页
学习
活动
专区
圈层
工具
MCP广场
文章/答案/技术大牛
搜索
搜索
关闭
发布
文章
问答
(9999+)
视频
沙龙
1
回答
导出
的
PHPMyAdmin数据库小于PHPMyAdmin控制面板
中
的
数据库大小
php
、
mysql
、
sql
、
phpmyadmin
我需要备份我们
的
客户之一
的
网站,并已出口
的
the服务器
和
PHP数据库上
的
文件。 这个PHP数据库是通过PHPMyAdmin管理
的
,我对PHP或SQL一无所知。我注意到在我
的
工作站上数据库
的
导出大约是4MB,但在PHPMyAdmin上数据库
的
大小是8.7MB。导出文件是否可能是压缩文件?如何检查导出是否正确?有没有可以用来查看SQL数据库
的
客户端应用程序?亲切
的
问候
浏览 0
提问于2018-06-07
得票数 2
1
回答
如果磁盘
空间
用完了,但有很多data_free,
MySQL
服务器会停止工作吗?
mysql
、
space
我有几个
表
,其中有非常大量
的
插入
和
删除
。数据在
表
中保留大约2小时
后
才会被
删除
。在任何一点,服务器上
的
数据都远远少于
可用
的
磁盘
空间
。 但是,由于行
删除
操作没有释放磁盘
空间
,所以
表
的
大小一直在增加。通过对表大小运行OPTIMIZE,我可以将
表
大小恢复到合理水平。然而,这会使系统停机
的
时间比我希望<
浏览 2
提问于2011-02-14
得票数 0
2
回答
Cassandra CQL 3.2.1清楚
的
列
数据
cassandra
、
cql3
我需要使用CQL从
表
中
的
列
中
清除数据,我在单个节点上尝试了下面的测试,它运行良好。 但是,这会在许多节点
和
不同
的
复制因素上运行吗?
浏览 1
提问于2016-04-22
得票数 0
回答已采纳
1
回答
MySQL
--我可以询问某些行或
列
占用了多少磁盘
空间
吗?
mysql
、
diskspace
我在
MySQL
中有一个巨大
的
表
,并希望通过优化数据使其变得更小。 现在我在想,
MySQL
是否有一些特性,允许我通过
删除
某些行或
列
来计算我会节省多少字节?当然,我可以复制表,并比较
删除
行或
列
后
使用
的
存储
空间
,但这花费了大量时间。一些数据,我可以迁移或
删除
和
构建不同
的
应用程序,而不破坏任何东西。这个问题是关于评估可能取得
的
成果,以及
浏览 2
提问于2019-01-22
得票数 5
回答已采纳
3
回答
在
MySQL
中
information_schema.TABLES.DATA_FREE是什么意思?
mysql
我不完全确定information_schema.TABLES.DATA_FREE在
MySQL
中
是什么意思。谢谢。
浏览 0
提问于2012-03-16
得票数 27
1
回答
如何回收
MySql
磁盘
空间
mysql
、
database
我在
MySql
服务器中有一个
表
,该
表
包含大约100万行。只是因为一个列表每天占用更多
的
磁盘
空间
。该
列
的
数据类型为Mediumblob。
表
的
大小约为90 GB。在每次插入行之后,我会做一些处理,然后在不需要这个
列
之后进行一些处理。 因此,对于该
列
,如果在处理该行
后
将值设置为NULL,那么
MySql
是否为下一行插入使用了这个空
空间
?
MySql
浏览 0
提问于2018-01-07
得票数 10
回答已采纳
2
回答
如何
删除
MySQL
崩溃
后
出现
的
名为"logs/#sql-ib203“
的
表
?
mysql
、
sql
、
innodb
您
的
SQL语法出现错误;请检查与您
的
MySQL
服务器版本对应
的
手册,以便在第1行使用“/#sql-ib203”附近
的
正确语法。
表
logs/#sql-ib203出现在数据库崩溃
后
(在重新索引
和
删除
logs数据库
中
的
表
中
的
某些属性时,磁盘
空间
不足)。SHOW TABLES没有列出
表
logs
浏览 2
提问于2013-06-19
得票数 4
1
回答
非常大
的
MySQL
数据库,
删除
了一
列
,并且数据库
的
大小增加了50%。
mysql
、
database
、
phpmyadmin
我有一个20 of
的
MySQL
数据库,它在一个
表
中
包含大约3000万行数据。我想
删除
该
表
中
的
一
列
,以清除一些
空间
。我通过phpMyAdmin
删除
了该
列
,它花费了大约15分钟,并检查了服务器
中
的
磁盘使用情况。在
删除
了一个填充了数据
的
列
之后,它使用了从20 to到28 to
的
数据
浏览 2
提问于2014-07-03
得票数 1
回答已采纳
2
回答
如何回收已
删除
LOB
的
存储
oracle
我有一个LOB
表
空间
。目前拥有12 9GB
中
的
9 9GB
可用
空间
。而且,据我所知,
删除
记录不会回收
表
空间
中
的
任何存储
空间
。我担心
的
是
空间
耗尽了--
表
空间
可用
的
12 GB
空间
中有9 GB,我想在请求更多
空间
之前弄清楚如何回收
空间
。 LOB<e
浏览 3
提问于2010-06-15
得票数 6
1
回答
删除
后
Mysql
表
索引长度不变
mysql
、
indexing
我在一个有1M条记录
的
表
上创建了几个索引,index_length增加了,然后
删除
了我创建
的
索引,但index_length并没有减少。
浏览 136
提问于2020-01-16
得票数 2
回答已采纳
2
回答
表
上
的
MySQL
ALTER太大,无法复制
mysql
当向MyISAM
表
添加
列
时,
MySQL
将Create>Copy>Drop>Rename。我有一个足够大
的
表
,不能在服务器剩余
的
空闲
空间
中复制。尝试添加
列
将导致磁盘填充。在这里,时间不是问题,
表
可用
性也不是问题,只有磁盘
空间
。 除了将数据复制到另一台服务器、截断、更改
和
复制之外,有没有一种方法可以在不创建临时
表
和
复制所有数据<em
浏览 6
提问于2012-01-06
得票数 8
2
回答
将文本值设置为null并不会减少
MySQL
表
的
磁盘
空间
使用量。
mysql
、
amazon-web-services
、
innodb
、
diskspace
、
rds
我试图在
MySQL
5.6.23
的
RDS实例
中
减少
表
的
磁盘
空间
使用。它是一个包含大约800万行
和
30
列
的
InnoDB
表
。其中几个
列
的
类型为TEXT NULL DEFAULT NULL。
表
之所以如此大
的
原因之一是因为通过一个名为“deleted”
的
标志
列
将它们标记为已
删除
,而不是
删除</
浏览 4
提问于2015-11-16
得票数 2
回答已采纳
1
回答
mysql
myisam datetime 5.6.10至5.5.10
表
损坏
mysql
、
version
、
rsync
、
myisam
、
corruption
我在一个服务器A上有MySQLVersion5.6.10,我正在创建和填充myisam
表
。创建
的
表
包含int、varchar
和
datetime字段。当我将这个
表
从服务器A同步到服务器B(其中包含
MySQL
5.5.10)时,我得到以下错误错误1033 (HY000):文件
中
的
错误信息: test1.frm 对于没有日期时间字段
的
表
,此过程不会出现任何错误即使我从服务器A获取
表
的
转储,
浏览 3
提问于2014-02-07
得票数 1
回答已采纳
1
回答
Mysql
:将int字段设置为unsigned可以节省大量
空间
。为什么?
mysql
我
的
印象是,将int字段设置为signed vs unsigned不会节省任何
空间
。今天,我将一些
列
设置为unsigned,因为它们从不存储负值,并且注意到
表
大小减少了15%。当我将它们
的
int
列
设置为unsigned时,我
的
一些
表
的
大小并没有减小,而一些
表
的
大小却大大减小了。有人对此有什么解释吗?
浏览 0
提问于2011-10-06
得票数 3
回答已采纳
3
回答
如果地址
空间
是连续
的
,对标识
列
的
查找是否更快?
sql
、
sql-server-2008
、
identity
、
fragmentation
、
address-space
如果我有一个带有IDENTITY
列
(bigint)
的
非常大
的
表
,并且这个
表
可能会被
删除
,那么地址
空间
(
可用
的
If )
的
碎片会导致SELECTS变慢吗?Clarification: 所谓地址
空间
碎片,我指的是ID
列
中
的
值所留下
的
空白,而不是从
表
中
删除
行时在磁盘上出现
的<
浏览 5
提问于2011-06-06
得票数 2
回答已采纳
1
回答
更新为null时
MySQL
中
的
BLOB数据管理?
mysql
、
storage
、
blob
我有几个事务性
表
,它们在逻辑上放置了text,在
MySQL
中有一个blob
列
。经过一段时间
后
,在X天以上
的
行上不需要这些数据
列
。我需要尽可能
的
注意储存。这是在集群
中
具有有限本地
和
NFS存储
空间
的
多个节点上进行
的
,因此将它们保持为不可行
的
文件是不可行
的
。有两种明显
的
解决方案,这是确保释放blob
表
存储
的<
浏览 3
提问于2012-03-06
得票数 0
1
回答
删除
mySQL
表
后
,磁盘
空间
何时恢复
可用
?
mysql
、
storage
如果我
删除
了innodb
表
,什么时候可以回收磁盘
空间
?它是立即发生
的
吗? 使用记录而不是整个
表
怎么样?
浏览 1
提问于2012-01-23
得票数 1
回答已采纳
1
回答
超大型日志文件
mysql
、
windows
、
logs
接着,服务器
的
硬盘
空间
用完了。当我
删除
日志时,它说我没有管理员特权。(我知道)
浏览 0
提问于2012-04-25
得票数 3
2
回答
删除
表
和
列
后
是否在
MySQL
中
释放
空间
?
sql
、
mysql
、
mysqldump
我有一个大约20 of
的
数据库。我需要
删除
5个
表
,并
删除
其他3个
表
中
的
一些
列
。如何从
MySQL
回收此
空间
。我已经读过转储数据库并将
浏览 0
提问于2010-12-03
得票数 5
回答已采纳
4
回答
MySQL
分区
和
临时
表
mysql
、
partitioning
、
temp-tables
它
的
目的是对事件进行分组,将集合
的
第一个事件ID放在EVENT_ID
列
中
。示例:从1000开始编写4个事件将导致事件1000,1001,1002,1003,所有事件
的
EVENT_ID都是1000。由于使用了InnoDB实现,
MySQL
是
表
中
唯一可以使用
的
引擎,自分区之前它就一直是InnoDB。编辑:当
删除
ENGINE=MEMORY时,它确实有效,但是运行SHOW CREATE TABLE会告诉我它使用
的</e
浏览 20
提问于2022-05-22
得票数 0
点击加载更多
热门
标签
更多标签
云服务器
ICP备案
对象存储
实时音视频
云点播
活动推荐
运营活动
广告
关闭
领券