腾讯云
开发者社区
文档
建议反馈
控制台
登录/注册
首页
学习
活动
专区
圈层
工具
MCP广场
文章/答案/技术大牛
搜索
搜索
关闭
发布
文章
问答
(9999+)
视频
沙龙
1
回答
MariaDB
/
MySQL
临时
表
会
占用
整个
磁盘空间
mysql
、
mariadb
有时,当我们查询该视图时,
MariaDB
10会在磁盘上创建
临时
文件(在/tmp中)。文件大小超过40 it这似乎是无穷无尽的。这种
表
可以增长到多大?
浏览 12
提问于2017-01-19
得票数 0
1
回答
表
MYSQL
的不正确密钥文件
mysql
当我想按查询分组时,我会收到以下错误消息:它是一个InnoDB
表
,
浏览 5
提问于2014-09-13
得票数 3
回答已采纳
1
回答
当
磁盘空间
较低时,如何修复大型myisam数据库?
mariadb
、
myisam
、
disk-space
MariaDB
10 + CentOS 5.x我现在正在运行repair table foo_TABLE;,但我不确定是否
会
遇到同样的问题。此时,我已经从系统中挤出了尽可能多的空闲
磁盘空间
。还有其他选择吗?是否有更节省<
浏览 0
提问于2016-07-30
得票数 0
2
回答
错误:
MySQL
服务器在运行查询时消失了
ubuntu-12.04
我正从命令提示符正确地连接到
MariaDB
,我有一个名为Dealer的数据库,其中有一些
表
,但是当我运行任何查询时,它给出了一个error.My步骤如下:使用经销商;现在误差八度错误2006 (HY000):
MySQL
服务器已经消失,没有连接。试图重新连接..。错误2002 (HY000):无法通过套接字'
浏览 0
提问于2014-08-21
得票数 -1
1
回答
MariaDB
10.3.22 innodb_status_output持续打开
mysql
、
mariadb
、
innodb
MariaDB
10.3.22 innodb_status_output保持自动打开 根据
MySQL
文档,https://dev.
mysql
.com/doc/refman/8.0/en/innodb-troubleshooting.html,"InnoDB在以下情况下
临时
启用标准InnoDB监视器输出:1.长信号量等待2.InnoDB在缓冲池中找不到空闲块3.缓冲池的67%以上被锁堆或自适应散列索引
占用
“
MariaD
浏览 24
提问于2020-10-21
得票数 0
1
回答
MariaDB
复制服务器磁盘使用率删除
mysql-replication
、
mariadb
我在2台
MariaDB
7.0服务器上安装了一个CentOS主从服务器.今天,我在主服务器上扩展了一个LVM卷(因为它已经满了)。扩展分区后,我重新启动服务器并将从服务器重新连接到它。但是,在我的监视(Cacti)中,我注意到从主机上的
磁盘空间
使用情况出现了非常“可疑”的自由下降。我不知道为什么。当重新连接到主服务器时,从节点是否
会
丢弃/旋转绑定日志?所以一切看起来都很好,我只是无法解释
磁盘空间
使用量的大幅下降,有人有什么想法吗?
浏览 0
提问于2015-03-20
得票数 1
1
回答
PrestaShop无缘无故地在/tmp中创建#sql_文件
mysql
、
mariadb
、
prestashop
、
temp-tables
Prestashop创建
临时
表
,这些
临时
表
被放置在/tmp中,因为这是在my.cnf中配置的,这是可以的,但问题是为什么会生成它们以及什么
会
导致这些
临时
表
。文件示例:
mysql
:
mysql
/tmp/#sql_c2d_3.MAD 我的服务器是centos 7,
mariadb
10.3,php 7.1。如果还有什么需要,我很乐意与大家分享。我的服务器是centos7,
mariad
浏览 51
提问于2019-04-15
得票数 1
1
回答
为什么在
MySQL
上删除
表
的某些行后,我的空闲
磁盘空间
会
减少?
mysql
、
sql
、
windows
、
memory
我在一个
表
中删除了数千行,但(C:)中的空闲空间从40 Gb减少到15 Gb。发生了什么?它不是应该上升的吗? 我已经重新启动了
MySQL
服务器,甚至我的计算机,但问题仍然存在。我使用的是Windows10和
MySQL
8.0
浏览 25
提问于2019-07-18
得票数 2
回答已采纳
1
回答
将新磁盘附加到Azure Linux
azure
、
azure-storage
我已经在Azure的A4 Linux中安装了
mysql
,
磁盘空间
已经用完了。我看到主
磁盘空间
仅为29 of,
临时
磁盘空间
为600 of,但我不想将
mysql
的数据存储到
临时
磁盘,因为可能
会
丢失这些数据。2)如果我附加一个磁盘,当主
磁盘空间
耗尽时,
mysql
数据
会
自动分发到这个磁盘吗?或者我应该做进一步的调整(即更改
mysql
的data_dir或其他东西)?
浏览 0
提问于2014-07-11
得票数 0
回答已采纳
2
回答
Mysqldump从
mysql
到
mariadb
-数据库大小的差异
mysql
、
database
、
mariadb
我想从
mysql
切换到
mariadb
,为此,我导出了旧数据库并将它们导入到一个新的
mariadb
服务器,现在我遇到了一个问题,即新导入的数据库比原来的要小。我做了以下工作: 如果在想查看数据库有多大,我会看到以下内容:
浏览 5
提问于2015-10-26
得票数 1
回答已采纳
1
回答
MySQL
在tmp文件夹中生成大型.MYD文件,导致服务器速度减慢
mysql
在linux服务器/tmp文件夹中,我们不确定什么时候和为什么创建了许多大型文件(.MYD和.MYI),这导致了web服务器的速度减慢,我们使用的
临时
解决方案是重启服务器,但是这个问题有时还是会发生的。我们使用
MySQL
5.1数据库。存储引擎是myISAM。📷
浏览 0
提问于2021-12-15
得票数 0
回答已采纳
1
回答
哪个数据库是面向性能的,
MySQL
还是
MariaDB
?
mysql
、
database
、
database-tuning
、
mariadb
哪个数据库是面向性能的,
MySQL
还是
MariaDB
? 有很多的教程或者其他的选择吗?
浏览 3
提问于2010-11-04
得票数 3
1
回答
我在
MariaDB
中创建了一个过程,但它给出了错误"#1064“
sql
、
mariadb
、
procedure
我正在为
MariaDB
中的拆分字符串创建过程,但它给出了错误 "#1064 -您的SQL语法中有一个错误;有关使用'TRUNCATE TABLE splittedstringtable‘的正确语法,请查看与您的
MariaDB
服务器版本对应的手册。
浏览 13
提问于2020-04-09
得票数 0
1
回答
MariaDB
tmpdir &
表
复制操作
mariadb
、
innodb
、
temporary-tables
我有一个Linux服务器&
MariaDB
v10.0.33,其中tmpdir是tmpfs (ram),用于快速
临时
表
访问;tmpfs的大小显然是有限的。
MariaDB
似乎对alter操作(
表
副本)使用相同的tmpdir位置,这需要一个
表
副本;如果
表
是很多Gb的话,这些操作可能需要很大的空间。旧的
MySQL
版本分别配置“
表
复制”和“
临时
表
”;
表
副本写入
表
空
浏览 0
提问于2018-01-24
得票数 0
1
回答
做"small_table LEFT JOIN large_table“是不是不好的做法?
mysql
、
indexing
我正在连接到一个我无法管理的数据库,我编写了一个查询,它在两个
表
之间进行了左连接--一个小
表
和一个大几个数量级的
表
。在某个时候,数据库返回了这个错误: 我联系了管理员,有人告诉我,我得到了这个错误,因为我做了错误的左联接,我永远不应该离开连接一个小
表
到一个大
表
他们给出的原因是,当按我的方式完成时,
MySQL
将尝试创建一个太大的
临时
表<
浏览 2
提问于2012-08-31
得票数 2
回答已采纳
1
回答
利用Docker和Jenkins实现天桥自动迁移
docker
、
jenkins
、
docker-compose
、
flyway
我想自动化我们的
MariaDB
数据库的天桥迁移。出于测试目的,我将以下服务添加到只运行info命令的info中。flyway: command: -url=jdbc:
mariadb
://
mariadb
_service -schemas=$${
MYSQL
_DATABASE} -table=schema_version -connectRetries=60 info - ./db
浏览 1
提问于2019-02-13
得票数 1
1
回答
最大用户数
mysql
我也不知道可以在
MySQL
上创建的数据库用户的最大数量。 在
MySQL
上可以创建多少用户?
浏览 1
提问于2015-04-19
得票数 2
回答已采纳
2
回答
删除行并获得空间postgresql
sql
、
postgresql
、
autovacuum
但实际上,在这个命令之后,
磁盘空间
变得更小了。我想做的事很简单。删除行并获取空格。
浏览 3
提问于2017-12-16
得票数 4
1
回答
选择查询
会
导致高写入IOP吗?
mysql
、
amazon-web-services
、
amazon-rds
我们有一个AWS RDS
mysql
数据库,它经常挂起似乎是高写入IOP和高写入延迟的数据。在这段时间里,我们不相信我们正在进行任何繁重的DB编写。不过,我有一个理论,即我们的select查询之一可能是创建大型
临时
表
,因为我们运行具有大量键的聚合查询。我们在几百万行上运行一个查询,并进行分组,结果可以有10万行。
浏览 4
提问于2022-08-24
得票数 0
2
回答
如何避免磁盘上的
磁盘空间
不足?
linux
、
mysql
、
ramdisk
我正在考虑将将我的
MySQL
数据库的数据库的放到一个ramdisk上放在Linux下。这样做的原因是为了绕过4gb内存中
临时
表
的最大值 in
MySQL
。我唯一担心的是,如果基于MyISAM的ramdisk
临时
表
会
变得比ramdisk更大,那么如何避免
磁盘空间
外的错误?你能不能--如何创建一个溢出机制?
浏览 0
提问于2011-09-27
得票数 1
回答已采纳
点击加载更多
热门
标签
更多标签
云服务器
ICP备案
对象存储
实时音视频
即时通信 IM
活动推荐
运营活动
广告
关闭
领券