首页
学习
活动
专区
圈层
工具
发布

远程连接MySQL(MariaDB)数据库

IP:172.16.230.200 在实际的工程或项目开发中,如果数据库服务器被放置在机房或机房的机柜中,开发或工程人员只能通过网络远程连接数据库进行操作时就需要用到我下面介绍的内容了。...1、客户端远程连接数据库需要先安装mysql的客户端工具,mysql的客户端工具网上有很多,大家可以百度一下。...4、客户端使用用户名和密码尝试通过网络远程连接数据库 C:\mysql5628\bin>mysql -h 172.16.230.15 -u root -p Enter password: ******...(2)为其他主机远程连接数据库开放访问权限,重新登入数据库: MariaDB [(none)]> use mysql;   //选择mysql数据库进行操作 Reading table information...只有这些仍然不够,我们只是开启了MySQL监听远程连接的选项,接下来需要给对应的MySQL账户分配权限,允许使用该账户远程连接到MySQL 输入 select User, host from mysql.user

29.8K53
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Navicat for mysql 远程连接 mySql数据库10061错误问题

    安装完mysql后,此时只是本机访问mysql,其他的任何机器都是无法访问的,Navicat for mysql更是无法使用, 然后进行如下操作: update user set host ='%'...where user='root'; grant all on *.* to root@'%' identified by 'root'; flush privileges; 执行以上3个命令,本以为可以用...Navicat 可以连接了,谁知报了10061错误: 经常一番资料查找,有人说: 在服务端MySQL文件夹下找到my.ini文件。...居然在这个文件中,便修改: 修改bind-address = 127.0.0.1 为 bind-address = 0.0.0.0 :wq --保存退出 之后要重启mysql...服务,很多人是这么启动的: sudo /etc/init.d/mysql restart --重启服务 但我是这么启动的: sudo service mysql restart;

    11.6K20

    设置mysql用户密码(5.65.7)、远程连接数据库、常用命令

    第13章 MySQL常用操作 MySQL版本 5.6.35 13.1 设置、更改root用户密码 首次直接使用mysql会提示‘该命令不存在’,原因是还没有将该命令加入环境变量,如果要使用该命令,需要使用其绝对路径...13.2 连接mysql(本地、远程) 远程连接:使用IP/port连接 [root@adailinux ~]# mysql -uroot -p123456 -h127.0.0.1 -P3306 Welcome...本地连接:使用socket连接 [root@adailinux ~]# mysql -uroot -p123456 -S/tmp/mysql.sock Welcome to the MySQL monitor...显示所有数据库 [root@adailinux ~]# mysql -uroot -p'123456' -e "show databases" Warning: Using a password on...13.3 MySQL常用命令 查看库信息: 以下命令需要在切换库(use mysql)之后执行: 编辑库: 注: 以上命令均需要在mysql下执行;在mysql中每行命令末尾加上分号,表示该行命令执行结束

    4.5K50

    MySQL 开启远程连接

    一、MySQL 开启远程连接需要先在服务器上登录到 MySQL mysql -u root -p 然后 Enter password: 二、修改 root 账户的 Host 1、打开 mysql 数据库...use mysql; 2、查看 user 数据表当前已有的数据 select * from user \G; 3、修改一条 root 数据,并刷新MySQL的系统权限相关表 update user set...Host = '%' where Host = 'localhost' and User='root'; flush privileges; 或者使用 grant 命令重新创建一个用户 grant all....* to root @"%" identified by "root"; flush privileges; 三、注意事项 当出现 10038错误时 2003 - Can't content to MySQL...server on '127.0.0.1' (10038) ,需要 check 以下几点; 1、记得在服务器安全组开放对应端口 2、开放了安全组后还是连接不上,就要检查防火墙了,可以参考文章:Centos

    9.1K30

    Navicat 远程连接 MySQL

    Navicat 远程连接 MySQL 相信大家都有在远程服务器上进行开发吧,其中 MySQL 的使用率应该也会挺高,如果使用 Navicat 等可视化工具来操作远程数据库不失为一种很好的选择,避免了在命令行写...下面简单介绍一下 Navicat 连接远程数据库的操作。 1 首先我们需要更改 3306端口,查看3306 端口是否对外开放,MySQL 默认情况下是不开放对外访问功能的。...可以看出,mysql的3306端口只是监听本地的连接,这样就阻碍了外部IP对该数据库的访问,修改 MySQL 配置文件 my.conf : vim /etc/mysql/my.cnf 找到 # Instead...2 我们进入 MySQL 命令界面,运行下列SQL 语句,查看用户是否具有访问权限: use mysql; select user, host from user; 返回结果如下: ?...最后重启一下 MySQL 服务: sudo restart mysql 3 服务端设置好了,我们在 Navicat 客户端设置一下连接: 打开 Navicat,点击左上方的 "连接",设置一下数据库的用户名

    28K31
    领券