wordpress插件快速全站https升级改造——墨涩网

相信很多人在给自己的网站添加SSL证书后会,再用浏览器https下访问网站的时候,依然显示不安全或者不可信的网站,没有出现绿色的安全锁,这是因为在你的网站上依然存在http的链接资源,没有实现全站完全https安全加密化,如果要对运行了很长时间的网站升级全站https,改造升级起来比较麻烦,尤其是对新手站长来说更加无从下手。但是对于用wordpress搭建的博客来说,插件可以快速帮助你实现全站https升级,不用那么麻烦手动改造,下面是我测试过的两款插件,都可以实现自动改造https的目的。

全站https升级改造前(已经安装SSL证书,采用https访问的时候依然提示并非完全安全)

全站https升级改造后(利用插件全站https升级改造后,提示安全!)

一:SSL 不安全内容修复器

这款插件安装启用后,需要在设置中选择https改造的选项,你可以根据自己网站的情况由低到高尝试不同的选项,不同的选项对网站影响程度也不同,一般倒数第二项就可以实现全站https升级了,不推荐最后一个选项,因为最后一项选择会降低网站的性能,得不偿失。

一:Really Simple SSL

这款插件的设置相对比较简单,保持默认的设置一般就可以了,如果启用插件后出现了错误,可以进插件设置里面的除错设置里面修改即可。

经过测试,wordpress安全可以利用上面两款插件实现快速,当然此方式仅在老站改造升级的时候推荐使用,可以省去很多麻烦事,但如果你是新建站点的话不推荐使用插件,最好一开始就手动配置好一切,并且在后面的网站更新中也避免使用非https的资源。

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20181219A1IU5Y00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 yunjia_community@tencent.com 删除。

扫码关注云+社区

领取腾讯云代金券