前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDUOJ---A + B Again

HDUOJ---A + B Again

作者头像
Gxjun
发布2018-03-21 11:43:34
7190
发布2018-03-21 11:43:34
举报
文章被收录于专栏:ml

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11855    Accepted Submission(s): 5178

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file. Each case consists of two hexadecimal integers A and B in a line seperated by a blank. The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

0

2C

11

-2C

-90

Author

linle

涉及到进制格式问题:X 表示大写的16进制,x表示小写的16进制;

代码

代码语言:javascript
复制
#include<stdio.h>

int main()
{
    _int64 a,b;
    while(scanf("%I64X%I64X",&a,&b)==2)
    {
        if(a+b<0)
        printf("-%I64X\n",-(a+b));
        else
            printf("%I64X\n",a+b);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2013-08-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • A + B Again
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档