前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >hdu 1598 find the most comfortable road(枚举+卡鲁斯卡尔最小生成树)

hdu 1598 find the most comfortable road(枚举+卡鲁斯卡尔最小生成树)

作者头像
Gxjun
发布2018-03-26 15:55:26
5080
发布2018-03-26 15:55:26
举报
文章被收录于专栏:mlml

find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3999    Accepted Submission(s): 1720

Problem Description

XX 星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ), 但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

Input

输入包括多个测试实例,每个实例包括: 第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。 接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000 然后是一个正整数Q(Q<11),表示寻路的个数。 接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

Output

每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input

4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2

Sample Output

1 0

Author

ailyanlu

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

 思路:  以不同的边为起点,构建一个最小树,求他们中最大边-最小边的长度。即可!

代码:

代码语言:javascript
复制
//#define LOCAL
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int inf=1000000;
int father[202];
struct node
{
   int a,b,c;
  bool operator <(node const &bb) const
  {
     return bb.c>c;  //小到大
  }
}tt[1005];
void init(int n)
{
   for(int i=1;i<=n;i++)
      father[i]=i;
}
int fin(int x)
{
    while(x!=father[x])
        x=father[x];
    return x;
}
void unin(int a,int b)
{
   father[a]=b;
}
int main()
{
   #ifdef LOCAL
     freopen("test.in","r",stdin);
    #endif
   int n,m;
   while(scanf("%d%d",&n,&m)!=EOF)
   {
         for(int i=1;i<=m;i++)
        scanf("%d%d%d",&tt[i].a,&tt[i].b,&tt[i].c);
      sort(tt+1,tt+(m+1));
     int q;
     scanf("%d",&q);
     while(q--)
     {
           int en,st;
           scanf("%d%d",&st,&en);
             int ans=inf;
           for(int i=1;i<=m;i++)
          {
                     init(n);
             for(int j=i;j<=m;j++)
             {
                 int fr=fin(tt[j].a);
                 int to=fin(tt[j].b);
                 if(fr!=to)unin(to,fr);
                   fr=fin(st);
                   to=fin(en);
                 if(fr==to)
                {
                    ans=min(ans,tt[j].c-tt[i].c);
                    break;
                }
             }
          }
          if(ans==inf)  ans=-1;
            printf("%d\n",ans);
     }
   }
  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014-11-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • find the most comfortable road
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档