前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU-1520 Anniversary party(树形DP)

HDU-1520 Anniversary party(树形DP)

作者头像
ShenduCC
发布2018-04-25 17:23:31
4680
发布2018-04-25 17:23:31
举报
文章被收录于专栏:算法修养算法修养

Anniversary party

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7566 Accepted Submission(s): 3321

Problem Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: L K It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 0 0

Output Output should contain the maximal sum of guests’ ratings.

Sample Input 7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

Sample Output 5

Source 这道题目和这一道几乎一样的, http://blog.csdn.net/dacc123/article/details/50354675 换汤不换药, 看懂了这篇博客的代码,这题自然就会了

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
#define MAX 6000
struct Node
{
    int value;
    int next;
}edge[MAX*2+5];
int tag[MAX+5];
int dp[MAX+5][2];
int n;
int root;
int tot;
int rat[MAX+5];
int head[MAX+5];
int vis[MAX+5];
void add(int x,int y)
{
    edge[tot].value=y;
    edge[tot].next=head[x];
    head[x]=tot++;
}
void dfs(int root)
{

    dp[root][1]=rat[root];
    dp[root][0]=0;
    vis[root]=1;
    for(int i=head[root];i!=-1;i=edge[i].next)
    {
        int k=edge[i].value;
        if(!vis[k])
        {
            dfs(k);
            dp[root][1]+=dp[k][0];
            dp[root][0]+=max(dp[k][0],dp[k][1]);
        }
    }


}
int main()
{
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        tot=0;
        memset(head,-1,sizeof(head));
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(tag,0,sizeof(tag));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&rat[i]);
        }
        scanf("%d%d",&a,&b);
        while(a!=0&&b!=0)
        {
            tag[a]=1;
            add(b,a);
            add(a,b);
            scanf("%d%d",&a,&b);
        }
        for(int i=1;i<=n;i++)
        {
            if(tag[i]==0)
            {
              root=i;
              break;
            }
        }
        dfs(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015-12-18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档