前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-1276-Cash Machine(多重背包)

POJ-1276-Cash Machine(多重背包)

作者头像
ShenduCC
发布2018-04-25 17:24:19
5210
发布2018-04-25 17:24:19
举报
文章被收录于专栏:算法修养算法修养

Cash Machine Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 30568 Accepted: 11018 Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes: @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. Sample Input

735 3 4 125 6 5 3 350 633 4 500 30 6 100 1 5 0 1 735 0 0 3 10 100 10 50 10 10 Sample Output

735 630 0 0 Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

标准的多重背包,没有什么变化,水题

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>

using namespace std;
#define MAX 1000
int n,m;
int a[MAX+5];
int b[MAX+5];
int dp[MAX*100];
void ZeroOnePack(int v,int w)
{
    for(int i=n;i>=w;i--)
        dp[i]=max(dp[i],dp[i-w]+v);
}
void CompletePack(int v,int w)
{
    for(int i=w;i<=n;i++)
        dp[i]=max(dp[i],dp[i-w]+v);
}
void MultiplyPack(int v,int w,int c)
{
    if(c*w>=n)
    {
        CompletePack(v,w);
        return;
    }
    int k=1;
    while(k<c)
    {
        ZeroOnePack(v*k,w*k);
        c-=k;
        k<<=1;
    }
    ZeroOnePack(c*v,c*w);
}
int main()
{

    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));

        for(int i=0;i<m;i++)
           scanf("%d%d",&a[i],&b[i]);


        for(int i=0;i<m;i++)
           MultiplyPack(b[i],b[i],a[i]);
        printf("%d\n",dp[n]);
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015-12-20 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档