前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-2039 To and Fro

POJ-2039 To and Fro

作者头像
ShenduCC
发布2018-04-26 10:35:19
3030
发布2018-04-26 10:35:19
举报
文章被收录于专栏:算法修养算法修养

To and Fro Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 8694 Accepted: 5847 Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character “x” to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2… 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input. Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces. Sample Input

5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0 Sample Output

theresnoplacelikehomeonasnowynightx thisistheeasyoneab

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
char a[205];
char b[25][25];
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        scanf("%s",a);
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            if((i/n)%2==0)
              b[i/n][i%n]=a[i];
            if((i/n)%2==1)
            {
                b[i/n][n-i%n-1]=a[i];
            }

        }
        int len2=len/n;
        for(int i=0;i<n;i++)
            for(int j=0;j<len2;j++)
                printf("%c",b[j][i]);
        printf("\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-01-07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档