前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-2184 Cow Exhibition(01背包变形)

POJ-2184 Cow Exhibition(01背包变形)

作者头像
ShenduCC
发布2018-04-26 11:10:08
7550
发布2018-04-26 11:10:08
举报
文章被收录于专栏:算法修养算法修养

Cow Exhibition Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 10949 Accepted: 4344 Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much fun…” - Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. Input

  • Line 1: A single integer N, the number of cows
  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. Output
  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5 -5 7 8 -6 6 -3 2 1 -8 -5 Sample Output

8 Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF = 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value of TS+TF to 10, but the new value of TF would be negative, so it is not allowed.

看了别人博客才会写。01背包中体积出现负数怎么办?,整体加上100000,就行了,dp[100000]就和dp[0]一样,表示总体积为0.体积为负数的物品,要从小到大,和正数的物品反过来,因为如果和正数的物品一样的顺序,最大体积会增大,最大体积是不变的。

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <math.h>

using namespace std;
#define MAX 99999999
int dp[200005];
int w[105];
int v[105];
int n;
int main()
{
    int ans;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<=200000;i++)
            dp[i]=-MAX;
        ans=0;
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&v[i]);

        dp[100000]=0;
        for(int i=1;i<=n;i++)
        {
            if(w[i]<0&&v[i]<0)
                continue;
            if(w[i]>0)
            {
                for(int j=200000;j>=w[i];j--)
                {
                    if(dp[j-w[i]]!=-MAX)
                    {
                        dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
                    }
                }
            }
            else
            {
                for(int j=w[i];j<=200000+w[i];j++)
                {
                    if(dp[j-w[i]]!=MAX)
                    {
                        dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
                    }
                }
            }
        }
        ans=-MAX;
        for(int i=100000;i<=200000;i++)
        {
            if(dp[i]>=0)
                ans=max(ans,dp[i]+i-100000);
        }
        printf("%d\n",ans);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-01-09 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档