前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-2356 Find a multiple(DFS,抽屉原理)

POJ-2356 Find a multiple(DFS,抽屉原理)

作者头像
ShenduCC
发布2018-04-26 11:11:21
4610
发布2018-04-26 11:11:21
举报
文章被收录于专栏:算法修养算法修养

Find a multiple Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 7133 Accepted: 3122 Special Judge Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k). Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set. Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them. Sample Input

5 1 2 3 4 1 Sample Output

2 2 3

dfs:

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
int a[10005];
int vis[10005];
int n;
int m;
int dfs(int x,int sum)
{
    if(sum%n==0&&sum>=n)
    {
        cout<<m<<endl;
        return 1;
    }
    for(int i=x+1;i<=n;i++)
    {
        m++;
        if(dfs(i,sum+a[i]))
        {
                cout<<a[i]<<endl;
                return 1;
        }
        m--;
    }
    return 0;

}
int main()
{

    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        m=0;
        if(!dfs(0,0))
            printf("0\n");

    }
     return 0;
}

抽屉原理改天补上

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-01-09 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档