前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 2476 String painter(区间DP)

HDU 2476 String painter(区间DP)

作者头像
ShenduCC
发布2018-04-26 11:26:10
7490
发布2018-04-26 11:26:10
举报
文章被收录于专栏:算法修养算法修养

String painter

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2792 Accepted Submission(s): 1272

Problem Description There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input Input contains multiple cases. Each case consists of two lines: The first line contains string A. The second line contains string B. The length of both strings will not be greater than 100.

Output A single line contains one integer representing the answer.

Sample Input zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd

Sample Output 6 7

这道题目完全没有思路,看了别人的题解。方法是先求空的字符数组变成目标字符数组,再求给定的字符数组变成目标字符数组。 虽然代码很短,确很值得我去思量,第二道区间DP题目

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
int dp[105][105];
int ans[105];
char s1[105];
char s2[105];
int main()
{
    while(scanf("%s%s",s1+1,s2+1)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int len=strlen(s1+1);
        for(int j=1;j<=len;j++)
        {
            for(int i=j;i>=1;i--)
            {
                dp[i][j]=dp[i+1][j]+1;
                for(int k=i+1;k<=j;k++)
                {
                    if(s2[k]==s2[i])
                        dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
                }
            }
        }
        for(int i=1;i<=len;i++)
            ans[i]=dp[1][i];
        for(int i=1;i<=len;i++)
        {
            if(s1[i]==s2[i])
                ans[i]=ans[i-1];
            else
            {
                for(int j=i-1;j>=1;j--)
                    ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
            }
        }
        printf("%d\n",ans[len]);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-03-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档