前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HUST 1606 - Naive

HUST 1606 - Naive

作者头像
ShenduCC
发布2018-04-26 11:53:51
4160
发布2018-04-26 11:53:51
举报
文章被收录于专栏:算法修养

1606 - Naive

时间限制:3秒 内存限制:128兆 779 次提交 138 次通过 题目描述 Give you a positive integer x, determine whether it is the sum of three positive cubic numbers. 输入 There’re several test cases. For each case: Only one line containing an integer x (1≤x≤10^6) 输出 For each test case, print “Yes” if it is or “No” if it isn’t. (See sample for more details) 样例输入 1 3 10 样例输出 No Yes Yes、

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[100005];
int b[1000005];
int cot;
void init()
{
    cot=0;
    for(int i=1;i<=200;i++)
    {
        if(i*i*i<=1000000)
         a[cot++]=i*i*i;
        else
            break;
    }
}
void init2()
{
     int cnt=0;
          for(int i=0;i<cot;i++)
          {
              for(int j=0;j<cot;j++)
              {
                  for(int k=0;k<cot;k++)
                  {
                      if(a[i]+a[j]+a[k]<=1000000)
                     b[a[i]+a[j]+a[k]]=1;
                  }

              }

          }

}
int main()
{
    int n;
    init();

            init2();
    while(scanf("%d",&n)!=EOF)
    {

          if(b[n])
          printf("Yes\n");
          else
              printf("No\n");
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-09 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档