前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >FZU 2140 Forever 0.5(找规律,几何)

FZU 2140 Forever 0.5(找规律,几何)

作者头像
ShenduCC
发布2018-04-26 16:09:27
5690
发布2018-04-26 16:09:27
举报
文章被收录于专栏:算法修养

Problem 2140 Forever 0.5 Accept: 371 Submit: 1307 Special Judge Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

  1. The distance between any two points is no greater than 1.0.
  2. The distance between any point and the origin (0,0) is no greater than 1.0.
  3. There are exactly N pairs of the points that their distance is exactly 1.0.
  4. The area of the convex hull constituted by these N points is no less than 0.5.
  5. The area of the convex hull constituted by these N points is no greater than 0.75. Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3 2 3 5 Sample Output

No No Yes 0.000000 0.525731 -0.500000 0.162460 -0.309017 -0.425325 0.309017 -0.425325 0.500000 0.162460

以原点为圆心,半径为1的圆内,以原点为顶点,变成为1的正三角形另外两个点在圆上,你会发现,两个点之间的那段弧,上的所有点都是满足条件的,所以只要三个顶点分别是正三角形的三个顶点,其余的点在弧上,都是正确的

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int n;
int t;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n<=3)
            printf("No\n");
        else
        {
            printf("Yes\n");

            printf("0.000000 0.000000\n");
            printf("0.500000 %.6f\n",-1.0*sqrt(3.0)/2);
            printf("-0.500000 %.6f\n",-1.0*sqrt(3.0)/2);
            for(int i=1;i<=n-3;i++)
                printf("-0.000000 -1.000000\n");
        }

    }
            return 0;

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-04-16 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档