前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 3367 Pseudoforest(Kruskal)

HDU 3367 Pseudoforest(Kruskal)

作者头像
ShenduCC
发布2018-04-26 16:57:10
5950
发布2018-04-26 16:57:10
举报
文章被收录于专栏:算法修养算法修养

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2382    Accepted Submission(s): 933

Problem Description

In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

Input

The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges. The last test case is followed by a line containing two zeros, which means the end of the input.

Output

Output the sum of the value of the edges of the maximum pesudoforest.

Sample Input

代码语言:javascript
复制
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0

Sample Output

代码语言:javascript
复制
3
5求出一个最大的子图(子图的每个连通分量最多有一个环) 用kruskal算法求出最大生成树  不过要判断是否有环  2树合并时 :若2个子树都有环不能合并 只有一个有环可以合并 但合并后的树有环 若2个子树都没环直接合并
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>

using namespace std;
#define MAX 10000
int n,m;
struct Node
{
	int x;
	int y;
	int w;
}a[MAX*10+5];
int father[MAX+5];
bool tag[MAX+5];
int cmp(Node a,Node b)
{
	return a.w>b.w;
}
int find(int x)
{
	if(x!=father[x])
		father[x]=find(father[x]);
	return father[x];
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
			break;
		for(int i=0;i<m;i++)
			scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
		for(int i=0;i<n;i++)
		{
			father[i]=i;
			tag[i]=false;
		}
		sort(a,a+m,cmp);
		int ans=0;
		for(int i=0;i<m;i++)
		{
             int xx=find(a[i].x);
			 int yy=find(a[i].y);
			 if(xx!=yy)
			 {
				 if(tag[xx]&&tag[yy])
					 continue;
				 ans+=a[i].w;
				 father[xx]=yy;
				 if(tag[xx]||tag[yy])
				 {tag[xx]=true;tag[yy]=true;}
			 }
			 else
			 {
				 if(tag[xx]||tag[yy])
					 continue;
				 ans+=a[i].w;
				 tag[xx]=true;tag[yy]=true;
			 }
		}
		printf("%d\n",ans);
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Pseudoforest
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档