前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1014 Waiting in Line (模拟)

PAT 1014 Waiting in Line (模拟)

作者头像
ShenduCC
发布2018-04-27 10:20:33
7160
发布2018-04-27 10:20:33
举报
文章被收录于专栏:算法修养算法修养

1014. Waiting in Line (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

代码语言:javascript
复制
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

代码语言:javascript
复制
08:07
08:06
08:10
17:00
Sorry
模拟题:#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue>

using namespace std;

int t[1005];
int l;
int start[1005];
int e[1005];
int n,m;
int k;
void fun(int time)
{
  int hh=time/60;
  int mm=time%60;
  printf("%02d:%02d\n",8+hh,mm);
}
int main()
{
  scanf("%d%d%d%d",&n,&m,&k,&l);
  for(int i=1;i<=k;i++)
    scanf("%d",&t[i]);
  int cnt=1;
  memset(e,-1,sizeof(e));
  queue<int> q[1005];
  for(int j=1;j<=m;j++)
  {
    for(int i=1;i<=n;i++)
    {
      if(cnt>k)
        continue;
      if(j==1)
        start[cnt]=0;
      q[i].push(cnt++);
    }
  }
  for(int i=0;i<540;i++)
  {
    int num=1e5;
    for(int j=1;j<=n;j++)
    {
      if(q[j].empty()) continue;
      int x=q[j].front();
      if(start[x]+t[x]==i)
      {
        e[x]=i;
        q[j].pop();
        if(!q[j].empty())
        {
          int x=q[j].front();
          start[x]=i;
        }
      }
    }
    if(cnt>k)
      continue;
    for(int j=1;j<=n;j++)
    {
      if(q[j].size()<m)
      {
        if(cnt>k)
          continue;
        if(q[j].empty())
          start[cnt]=i;
        q[j].push(cnt++);
      }
    }
  }
  for(int i=1;i<=n;i++)
  {
    if(!q[i].empty())
    {
      int x=q[i].front();
      if(start[x]<540)
        e[x]=start[x]+t[x];
    }
  }
  int pos;
  for(int i=1;i<=l;i++)
  {
    scanf("%d",&pos);
    if(e[pos]==-1)
      printf("Sorry\n");
    else
      fun(e[pos]);
  }
  return 0;

}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1014. Waiting in Line (30)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档