前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3204 Connect them

ZOJ 3204 Connect them

作者头像
ShenduCC
发布2018-04-27 11:19:39
5950
发布2018-04-27 11:19:39
举报
文章被收录于专栏:算法修养算法修养

Connect them


Time Limit: 1 Second      Memory Limit: 32768 KB


You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii = 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

代码语言:javascript
复制
2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

代码语言:javascript
复制
1 2 1 3
-1

Hints: A solution A is a line of p integers: a1a2, ...ap. Another solution B different from A is a line of q integers: b1b2, ...bq. A is lexicographically smaller than B if and only if: (1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br OR

(2) p < q and ai = bi for all 0 < i <= p

最小生成树:

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
const int INF=1e5;
struct Node
{
    int x;int y;
    int value;
}a[10005];
int cmp(Node a,Node b)
{
    if(a.value==b.value)
    {
        if(a.x==b.x)
        {
            return a.y<b.y;
        }
        return a.x<b.x;
    }
    else
        return a.value<b.value;
}
struct node
{
    int x;
    int y;
}ans[INF+5];
int cmp2(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    else
        return a.x<b.x;
}
int n;
int father[INF+5];
int find(int x)
{
    if(father[x]!=x)
        father[x]=find(father[x]);
    return father[x];
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int tot=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&a[++tot].value);
                a[tot].x=i;
                a[tot].y=j;
                if(a[tot].value==0)
                    a[tot].value=INF;
            }
        }
        sort(a+1,a+tot+1,cmp);
        for(int i=1;i<=n;i++)
            father[i]=i;
        int cot=0;
        for(int i=1;i<=tot;i++)
        {
            if(a[i].value==INF)
                continue;
            int xx=find(a[i].x);
            int yy=find(a[i].y);
            if(xx!=yy)
            {
                father[xx]=yy;
                ans[++cot].x=a[i].x;
                ans[cot].y=a[i].y;
            }
        }
        int root=find(1);
        bool res=true;
        for(int i=2;i<=n;i++)
        {
            find(i);
            if(father[i]!=root)
                res=false;
        }
        if(!res)
            printf("-1\n");
        else
        {
            sort(ans+1,ans+1+cot,cmp2);
            for(int i=1;i<=cot;i++)
            {
                if(i==cot)
                    printf("%d %d\n",ans[i].x,ans[i].y);
                else
                    printf("%d %d ",ans[i].x,ans[i].y);
            }
        }
        
        
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2017-02-24 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档