专栏首页绿盟科技安全情报【漏洞通告更新】WebSphere远程代码执行漏洞(CVE-2020-4450、CVE-2020-4449)

【漏洞通告更新】WebSphere远程代码执行漏洞(CVE-2020-4450、CVE-2020-4449)

通告编号:NS-2020-0036-1

2020-08-

TAG:

WebSphere、远程代码执行、CVE-2020-4450、CVE-2020-4449

漏洞危害:

攻击者利用此漏洞,可实现远程代码执行。

版本:

1.0

1

漏洞概述

北京时间2020年6月5日,IBM官方发布通告修复了WebSphere Application Server(WAS)中的一个高危远程代码执行漏洞和一个信息泄露漏洞,漏洞描述为IIOP协议上的反序列化漏洞,分配编号CVE-2020-4450和CVE-2020-4449,漏洞评分为9.8分和7.5分,漏洞危害较高,影响面较大。

CVE-2020-4450由绿盟科技安全研究团队报告给IBM,未经身份认证的攻击者可以通过IIOP协议远程攻击WAS服务器,在目标服务端执行任意代码,获取系统权限,进而接管服务器。

PS:WAS默认开启IIOP协议,攻击者无需认证即可远程攻击。

漏洞复现截图如下:

  • CVE-2020-4450
  • CVE-2020-4449

参考链接:

https://www.ibm.com/support/pages/node/6220276

SEE MORE →

2影响范围

受影响版本

  • WebSphere Application Server 9.0.0.0 - 9.0.5.4
  • WebSphere Application Server 8.5.0.0 - 8.5.5.17
  • WebSphere Application Server 8.0.0.0 - 8.0.0.15
  • WebSphere Application Server 7.0.0.0 - 7.0.0.45

注:WebSphere Application Server V7.0 和 V8.0官方已停止维护。

3漏洞防护

4.1 官方升级

目前官方已发布补丁修复了该漏洞,对于已停止维护的版本也提供了安全补丁,请受影响的用户尽快安装进行防护。

相关用户可通过IBM Installation Manager进行升级,根据提示进行版本更新、补丁安装。

用户也可至官网手动下载补丁并安装。

受影响版本

修复方法

补丁下载链接

9.0.0.0 - 9.0.5.4

安装补丁PH25074

https://www.ibm.com/support/pages/node/6220276

8.5.0.0 - 8.5.5.17

安装补丁PH25074

8.0.0.0 - 8.0.0.15

升级至8.0.0.15 版本,并安装补丁PH25074

7.0.0.0 - 7.0.0.45

升级至7.0.0.45版本,并安装补丁PH25074

注:安装补丁之前请先关闭WebSphere服务,安装完成后再将服务开启。

4.2 产品防护

绿盟科技网络入侵防护系统(IPS)、网络入侵检测系统(IDS)的用户可通过升级规则包至最新版本,实现对此漏洞利用行为的检测防护能力。安全产品规则版本号如下:

安全防护产品

规则版本号

升级包下载链接

规则编号

IPS、IDS

5.6.10.23150

http://update.nsfocus.com/update/downloads/id/107144

【24980】CVE-2020-4450

5.6.9.23150

http://update.nsfocus.com/update/downloads/id/107143

END

作者:绿盟科技威胁对抗能力部

声明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。

绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。

本文分享自微信公众号 - 绿盟科技安全预警(nsfocus_secwarning),作者:绿盟伏影实验室

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2020-08-07

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 【漏洞通告】WebSphere远程代码执行漏洞(CVE-2020-4534)

    北京时间2020年7月31日,IBM官方发布通告修复了WebSphere Application Server(WAS)中的一个远程代码执行漏洞(CVE-202...

    绿盟科技安全情报
  • 【漏洞通告】IBM Spectrum Protect Plus目录遍历与任意代码执行漏洞(CVE-2020-4703)通告

    9月15日,绿盟科技监测到IBM官方发布安全公告,修复了Spectrum Protect Plus的管理控制台中存在的目录遍历漏洞(CVE-2020-4711)...

    绿盟科技安全情报
  • 【漏洞通告】Treck TCP/IP协议库“ Ripple20”漏洞通告

    近日,以色列网络安全公司JSOF的研究人员在Treck公司开发的底层 TCP/IP 软件库中发现了19个0day漏洞,包括CVE-2020-11896、CVE-...

    绿盟科技安全情报
  • Typecho 支持异步回调版的评论邮件插件 Mailer

    Typecho 的评论邮件通知是个比较麻烦的问题, Handsome 主题使用文档里推荐的是 CommentToMail 插件不知道为啥在明月自己的阿里云ECS...

    明月登楼
  • mysql导出select结果到文件

    mysql -hxx -uxx -pxx -e "query statement" db > file  例如:  mysql -h127.0.0.1 -uro...

    joshua317
  • 大数加法

    语法:add(char a[],char b[],char s[]); 参数: a[]: 被乘数,用字符串表示,位数不限 b[]: 乘数,用字符串表示,位数不限...

    用户1154259
  • 使用 OpenWhisk 自建 Serverless 服务

    在尝试了使用 AWS 开发 Serverless 应用之后,我便想尝试使用 OpenWhisk 框架来搭建自己的 Serverless 服务。 Apache O...

    Phodal
  • 深入剖析最新IE0day漏洞

    在2018年4月下旬,我们使用沙箱发现了IE0day漏洞;自从在野外发现上一个样本(CVE-2016-0189)已经有两年多了。从许多方面来看,这个特别的漏洞及...

    伍尚国
  • TensorFlow什么的都弱爆了,强者只用Numpy搭建神经网络

    很多同学入门机器学习之后,直接用TensorFlow调包实现神经网络,对于神经网络内在机理知之甚少。

    大数据文摘
  • TensorFlow什么的都弱爆了,强者只用Numpy搭建神经网络

    很多同学入门机器学习之后,直接用TensorFlow调包实现神经网络,对于神经网络内在机理知之甚少。

    abs_zero

扫码关注云+社区

领取腾讯云代金券