首页
学习
活动
专区
圈层
工具
发布
精选内容/技术社群/优惠产品,尽在小程序
立即前往

PAT Advanced 1065

1065. A+B and C (64bit) (20)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

代码语言:javascript
复制
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

代码语言:javascript
复制
Case #1: false
Case #2: true
Case #3: false
代码语言:javascript
复制
代码语言:javascript
复制
#include<stdio.h>
typedef  long long int LONG;
int main()
{
	int n;
	scanf("%d",&n);
	LONG a,b,c,temp;
	int flag=0,count=0;
	while(scanf("%lld %lld %lld",&a,&b,&c)!=EOF)
	{
		count++;
		temp=a+b;
		/* 关键点是大数相加会溢出 */
		if(a>0 && b>0 && temp<=0)
			flag=1;
		else if(a<0 && b<0 && temp>=0)
			flag=0;
		else
			flag= (temp>c);

		if(flag)
			printf("Case #%d: true\n",count);
		else
			printf("Case #%d: false\n",count);
	}
	return 0;
}
举报
领券