首页
学习
活动
专区
圈层
工具
发布
精选内容/技术社群/优惠产品,尽在小程序
立即前往

PAT Advanced 1001

1001. A+B Format (20)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

代码语言:javascript
复制
-1000000 9

Sample Output

代码语言:javascript
复制
-999,991
代码语言:javascript
复制
代码语言:javascript
复制
#include<stdio.h>
void format(int sum,int count)
{
	if(sum/10!=0)
		format(sum/10,count+1);
	if(count%3==0&&sum/10!=0)
		printf(",");
	printf("%d",sum%10);
}

int main()
{
	int a,b;
	scanf("%d %d",&a,&b);
	int sum=a+b;
	if(sum<0)
	{
		sum=-sum;
		printf("-");
	}
	format(sum,1);
}
下一篇
举报
领券