首页
学习
活动
专区
工具
TVP
发布
精选内容/技术社群/优惠产品,尽在小程序
立即前往

九度OJ——1012畅通工程

题目描述: 某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 输入: 测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 注意:两个城市之间可以有多条道路相通,也就是说 3 3 1 2 1 2 2 1 这种输入也是合法的 当N为0时,输入结束,该用例不被处理。 输出: 对每个测试用例,在1行里输出最少还需要建设的道路数目。 样例输入: 4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0 样例输出: 1 0 2 998


思路:这是道并查集的简单应用,首先构造一个并查集,然后进行并操作,之后数连通分量个数,需要再修的路就是连通分量个数-1。 AC代码:

代码语言:javascript
复制
#include <iostream>
using namespace std;

const int MAX = 1010;

class UF{
    private:
        int data[MAX];
        int count;  //连通分量个数 
    public:
        //构造函数
        UF(int n){
            this->count = n;
            for(int i = 0 ; i < MAX ; i++){
                this->data[i] = -1;
            }
        }

        //查找操作
        int Find(int root){
            if(this->data[root] < 0){
                return root;
            }
            return this->data[root] = this->Find(this->data[root]);
        } 

        //并操作
        void Union(int root1,int root2){
            root1 = this->Find(root1);
            root2 = this->Find(root2);
            if(root1 == root2){
                return;
            }else if(root1 < root2){
                this->data[root1] += this->data[root2];
                this->data[root2] = root1; 
                this->count--; 
            }else{
                this->data[root2] += this->data[root1];
                this->data[root1] = root2; 
                this->count--;
            }
        }

        //连通分量个数 
        int getCount(){
            return this->count;
        }
};

int N,M;

int main()
{
    while(cin>>N){
        if(N == 0){
            break;
        }
        cin>>M;
        UF uf(N);
        for(int i = 0 ; i < M ; i++){
            int root1,root2;
            cin>>root1>>root2;
            uf.Union(root1,root2);
        }
        cout<<uf.getCount()-1<<endl;
    }

    return 0;
}

下一篇
举报
领券