前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3233 Matrix Power Series(矩阵快速幂)

POJ 3233 Matrix Power Series(矩阵快速幂)

作者头像
ShenduCC
发布2018-04-26 16:22:22
6300
发布2018-04-26 16:22:22
举报
文章被收录于专栏:算法修养算法修养

Matrix Power Series Time Limit: 3000MS Memory Limit: 131072K Total Submissions: 19338 Accepted: 8161 Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4 0 1 1 1 Sample Output

1 2 2 3

可以找到递推关系 : s[k]=s[k-1]+A^k; 然后构造矩阵,利用矩阵快速幂

这里写图片描述
这里写图片描述

具体见代码

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;
int n,k;
int m;
struct Node
{
    int a[65][65];

};
Node multiply(Node a,Node b)
{
    Node c;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            c.a[i][j]=0;
            for(int k=1;k<=n;k++)
            {
                (c.a[i][j]+=(a.a[i][k]*b.a[k][j])%m)%=m;
             }
        }
    } 
    return c;
}
Node quick(Node a,int x)
{
    Node c;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        c.a[i][j]=(i==j?1:0);
    for(x;x>0;x>>=1)
    {
        if(x&1) 
            c=multiply(c,a);
        a=multiply(a,a);
     }
    return c;
}
int main()
{
   while( scanf("%d%d%d",&n,&k,&m)!=EOF)
   {
    Node a;Node b;Node c;
    memset(a.a,0,sizeof(a.a));
    memset(b.a,0,sizeof(b.a));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&a.a[i][j+n]);
            b.a[i+n][j+n]=a.a[i][j+n];
        }
    for(int i=1;i<=n;i++)
    {
        b.a[i][i]=1;
        b.a[i+n][i]=1;
    }
    n=n*2;
    c=multiply(a,quick(b,k));
    for(int i=1;i<=n/2;i++)
        for(int j=1;j<=n/2;j++)
           if(j==n/2)printf("%d\n",c.a[i][j]);
           else printf("%d ",c.a[i][j]);
   }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-20 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档