ubuntu16 180501 更新说明

最近更新时间:2018-06-25 14:37:26

操作系统版本

ubuntu16

内核版本

4.4.0-119-generic.amd64

小版本号

180501

更新软件

软件名                                  更新前版本号                            更新后版本号
accountsservice.amd64                   0.6.40-2ubuntu11.1                      0.6.40-2ubuntu10                        
apparmor.amd64                          2.10.95-0ubuntu2                        2.10.95-0ubuntu2.6                      
apt.amd64                               1.2.12~ubuntu16.04.1                    1.2.15ubuntu0.2                         
apt-transport-https.amd64               1.2.12~ubuntu16.04.1                    1.2.15ubuntu0.2                         
apt-utils.amd64                         1.2.12~ubuntu16.04.1                    1.2.15ubuntu0.2                         
base-files.amd64                        9.4ubuntu4.2                            9.4ubuntu4                              
bash.amd64                              4.3-14ubuntu1.1                         4.3-14ubuntu1.2                         
bash-completion.all                     1:2.1-4.2ubuntu1.1                      1:2.1-4.2ubuntu1                        
bind9-host.amd64                        1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
binutils.amd64                          2.26.1-1ubuntu1~16.04.3                 2.26.1-1ubuntu1~16.04.6                 
bsdutils.amd64                          1:2.27.1-6ubuntu3.1                     1:2.27.1-6ubuntu3                       
ca-certificates.all                     20160104ubuntu1                         20170717~16.04.1                        
command-not-found.all                   0.3ubuntu16.04.2                        0.3ubuntu16.04                          
command-not-found-data.amd64            0.3ubuntu16.04.2                        0.3ubuntu16.04                          
console-setup.all                       1.108ubuntu15.2                         1.108ubuntu15                           
console-setup-linux.all                 1.108ubuntu15.2                         1.108ubuntu15                           
crash.amd64                             7.1.4-1ubuntu4                          7.1.4-1ubuntu4.2                        
dbus.amd64                              1.10.6-1ubuntu3                         1.10.6-1ubuntu3.1                       
dh-python.all                           2.20151103ubuntu1.1                     2.20151103ubuntu1                       
distro-info-data.all                    0.28ubuntu0.1                           0.28ubuntu0.3                           
dmidecode.amd64                         3.0-2ubuntu0.1                          3.0-2                                   
dnsutils.amd64                          1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
dpkg.amd64                              1.18.4ubuntu1.1                         1.18.4ubuntu1                           
eject.amd64                             2.1.5+deb1+cvs20081104-13.1             2.1.5+deb1+cvs20081104-13.1ubuntu0.16.04.1
gcc-5-base.amd64                        5.4.0-6ubuntu1~16.04.1                  5.4.0-6ubuntu1~16.04.9                  
gnupg.amd64                             1.4.20-1ubuntu3                         1.4.20-1ubuntu3.1                       
gpgv.amd64                              1.4.20-1ubuntu3                         1.4.20-1ubuntu3.1                       
grep.amd64                              2.25-1~16.04.1                          2.24-1                                  
grub2-common.amd64                      2.02~beta2-36ubuntu3.1                  2.02~beta2-36ubuntu3.17                 
grub-common.amd64                       2.02~beta2-36ubuntu3.1                  2.02~beta2-36ubuntu3.17                 
init.amd64                              1.29ubuntu2                             1.29ubuntu1                             
initramfs-tools.all                     0.122ubuntu8.1                          0.122ubuntu8                            
initramfs-tools-bin.amd64               0.122ubuntu8.1                          0.122ubuntu8                            
initramfs-tools-core.all                0.122ubuntu8.1                          0.122ubuntu8                            
init-system-helpers.all                 1.29ubuntu2                             1.29ubuntu1                             
isc-dhcp-client.amd64                   4.3.3-5ubuntu12.1                       4.3.3-5ubuntu12.9                       
isc-dhcp-common.amd64                   4.3.3-5ubuntu12.1                       4.3.3-5ubuntu12.9                       
kdump-tools.all                         1:1.5.9-5ubuntu0.2                      1:1.5.9-5ubuntu0.5                      
kexec-tools.amd64                       1:2.0.10-1ubuntu2                       1:2.0.10-1ubuntu2.4                     
keyboard-configuration.all              1.108ubuntu15.2                         1.108ubuntu15                           
klibc-utils.amd64                       2.0.4-8ubuntu1.16.04.1                  2.0.4-8ubuntu1                          
language-selector-common.all            0.165.3                                 0.165                                   
lib32stdc++6.amd64                      5.4.0-6ubuntu1~16.04.4                  5.4.0-6ubuntu1~16.04.9                  
lib32z1.amd64                           1:1.2.8.dfsg-2ubuntu4                   1:1.2.8.dfsg-2ubuntu4.1                 
libaccountsservice0.amd64               0.6.40-2ubuntu11.1                      0.6.40-2ubuntu10                        
libapparmor1.amd64                      2.10.95-0ubuntu2                        2.10.95-0ubuntu2.6                      
libapparmor-perl.amd64                  2.10.95-0ubuntu2                        2.10.95-0ubuntu2.6                      
libapt-inst2.0.amd64                    1.2.12~ubuntu16.04.1                    1.2.15ubuntu0.2                         
libapt-pkg5.0.amd64                     1.2.12~ubuntu16.04.1                    1.2.15ubuntu0.2                         
libasn1-8-heimdal.amd64                 1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libbind9-140.amd64                      1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libblkid1.amd64                         2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
libc6.amd64                             2.23-0ubuntu3                           2.23-0ubuntu10                          
libc6-i386.amd64                        2.23-0ubuntu7                           2.23-0ubuntu10                          
libc-bin.amd64                          2.23-0ubuntu3                           2.23-0ubuntu10                          
libcurl3-gnutls.amd64                   7.47.0-1ubuntu2                         7.47.0-1ubuntu2.6                       
libdb5.3.amd64                          5.3.28-11                               5.3.28-11ubuntu0.1                      
libdbus-1-3.amd64                       1.10.6-1ubuntu3                         1.10.6-1ubuntu3.1                       
libdns162.amd64                         1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libdns-export162.amd64                  1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libdrm2.amd64                           2.4.67-1ubuntu0.16.04.1                 2.4.67-1                                
libexpat1.amd64                         2.1.0-7ubuntu0.16.04.2                  2.1.0-7ubuntu0.16.04.3                  
libfdisk1.amd64                         2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
libfreetype6.amd64                      2.6.1-0.1ubuntu2                        2.6.1-0.1ubuntu2.3                      
libgcrypt20.amd64                       1.6.5-2                                 1.6.5-2ubuntu0.3                        
libglib2.0-0.amd64                      2.48.1-1~ubuntu16.04.1                  2.48.0-1ubuntu4                         
libglib2.0-data.all                     2.48.1-1~ubuntu16.04.1                  2.48.0-1ubuntu4                         
libgnutls30.amd64                       3.4.10-4ubuntu1.1                       3.4.10-4ubuntu1.3                       
libgnutls-openssl27.amd64               3.4.10-4ubuntu1.1                       3.4.10-4ubuntu1.3                       
libgssapi3-heimdal.amd64                1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libhcrypto4-heimdal.amd64               1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libheimbase1-heimdal.amd64              1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libheimntlm0-heimdal.amd64              1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libhogweed4.amd64                       3.2-1                                   3.2-1ubuntu0.16.04.1                    
libhx509-5-heimdal.amd64                1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libicu55.amd64                          55.1-7                                  55.1-7ubuntu0.3                         
libidn11.amd64                          1.32-3ubuntu1                           1.32-3ubuntu1.2                         
libisc160.amd64                         1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libisccc140.amd64                       1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libisccfg140.amd64                      1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libisc-export160.amd64                  1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libklibc.amd64                          2.0.4-8ubuntu1.16.04.1                  2.0.4-8ubuntu1                          
libkrb5-26-heimdal.amd64                1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libldap-2.4-2.amd64                     2.4.42+dfsg-2ubuntu3.1                  2.4.42+dfsg-2ubuntu3.2                  
liblwres141.amd64                       1:9.10.3.dfsg.P4-8ubuntu1               1:9.10.3.dfsg.P4-8ubuntu1.10            
libmount1.amd64                         2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
libnettle6.amd64                        3.2-1                                   3.2-1ubuntu0.16.04.1                    
libnl-3-200.amd64                       3.2.27-1                                3.2.27-1ubuntu0.16.04.1                 
libnl-genl-3-200.amd64                  3.2.27-1                                3.2.27-1ubuntu0.16.04.1                 
libpam-systemd.amd64                    229-4ubuntu7                            229-4ubuntu21.1                         
libperl5.22.amd64                       5.22.1-9                                5.22.1-9ubuntu0.2                       
libplymouth4.amd64                      0.9.2-3ubuntu13.1                       0.9.2-3ubuntu13                         
libpython3.5-minimal.amd64              3.5.2-2~16.01                           3.5.2-2ubuntu0~16.04.4                  
libpython3.5-stdlib.amd64               3.5.2-2~16.01                           3.5.2-2ubuntu0~16.04.4                  
libroken18-heimdal.amd64                1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
librtmp1.amd64                          2.4+20151223.gitfa8646d-1build1         2.4+20151223.gitfa8646d-1ubuntu0.1      
libsmartcols1.amd64                     2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
libssl1.0.0.amd64                       1.0.2g-1ubuntu4.1                       1.0.2g-1ubuntu4.10                      
libstdc++6.amd64                        5.4.0-6ubuntu1~16.04.4                  5.4.0-6ubuntu1~16.04.9                  
libsystemd0.amd64                       229-4ubuntu7                            229-4ubuntu21.1                         
libtasn1-6.amd64                        4.7-3ubuntu0.16.04.1                    4.7-3ubuntu0.16.04.3                    
libudev1.amd64                          229-4ubuntu7                            229-4ubuntu21.1                         
libuuid1.amd64                          2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
libwind0-heimdal.amd64                  1.7~git20150920+dfsg-4ubuntu1           1.7~git20150920+dfsg-4ubuntu1.16.04.1   
libxml2.amd64                           2.9.3+dfsg1-1ubuntu0.1                  2.9.3+dfsg1-1ubuntu0.5                  
linux-firmware.all                      1.157.2                                 1.157.16                                
linux-generic.amd64                     4.4.0.31.33                             4.4.0.21.22                             
linux-headers-generic.amd64             4.4.0.31.33                             4.4.0.21.22                             
linux-image-generic.amd64               4.4.0.31.33                             4.4.0.21.22                             
locales.all                             2.23-0ubuntu3                           2.23-0ubuntu10                          
login.amd64                             1:4.2-3.1ubuntu5                        1:4.2-3.1ubuntu5.3                      
lsb-base.all                            9.20160110ubuntu0.2                     9.20160110                              
lsb-release.all                         9.20160110ubuntu0.2                     9.20160110                              
lshw.amd64                              02.17-1.1ubuntu3.2                      02.17-1.1ubuntu3                        
makedumpfile.amd64                      1:1.5.9-5ubuntu0.2                      1:1.5.9-5ubuntu0.5                      
mount.amd64                             2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
mtr-tiny.amd64                          0.86-1ubuntu0.1                         0.86-1                                  
multiarch-support.amd64                 2.23-0ubuntu3                           2.23-0ubuntu10                          
ntfs-3g.amd64                           1:2015.3.14AR.1-1build1                 1:2015.3.14AR.1-1ubuntu0.1              
ntpdate.amd64                           1:4.2.8p4+dfsg-3ubuntu5.3               1:4.2.8p4+dfsg-3ubuntu5.8               
openssh-client.amd64                    1:7.2p2-4ubuntu1                        1:7.2p2-4ubuntu2.4                      
openssh-server.amd64                    1:7.2p2-4ubuntu1                        1:7.2p2-4ubuntu2.4                      
openssh-sftp-server.amd64               1:7.2p2-4ubuntu1                        1:7.2p2-4ubuntu2.4                      
openssl.amd64                           1.0.2g-1ubuntu4.1                       1.0.2g-1ubuntu4.10                      
passwd.amd64                            1:4.2-3.1ubuntu5                        1:4.2-3.1ubuntu5.3                      
perl.amd64                              5.22.1-9                                5.22.1-9ubuntu0.2                       
perl-base.amd64                         5.22.1-9                                5.22.1-9ubuntu0.2                       
perl-modules-5.22.all                   5.22.1-9                                5.22.1-9ubuntu0.2                       
plymouth.amd64                          0.9.2-3ubuntu13.1                       0.9.2-3ubuntu13                         
plymouth-theme-ubuntu-text.amd64        0.9.2-3ubuntu13.1                       0.9.2-3ubuntu13                         
python3.5.amd64                         3.5.2-2~16.01                           3.5.2-2ubuntu0~16.04.4                  
python3.5-minimal.amd64                 3.5.2-2~16.01                           3.5.2-2ubuntu0~16.04.4                  
python3-commandnotfound.all             0.3ubuntu16.04.2                        0.3ubuntu16.04                          
python3-distupgrade.all                 1:16.04.14                              1:16.04.12                              
python3-update-manager.all              1:16.04.3                               1:16.04.12                              
python3-urllib3.all                     1.13.1-2ubuntu0.16.04.1                 1.13.1-2                                
rsync.amd64                             3.1.1-3ubuntu1                          3.1.1-3ubuntu1.2                        
sensible-utils.all                      0.0.9                                   0.0.9ubuntu0.16.04.1                    
shared-mime-info.amd64                  1.5-2ubuntu0.1                          1.5-2                                   
sudo.amd64                              1.8.16-0ubuntu1.1                       1.8.16-0ubuntu1.4                       
systemd.amd64                           229-4ubuntu7                            229-4ubuntu21.1                         
systemd-sysv.amd64                      229-4ubuntu7                            229-4ubuntu21.1                         
tar.amd64                               1.28-2.1                                1.28-2.1ubuntu0.1                       
tcpdump.amd64                           4.7.4-1ubuntu1                          4.9.2-0ubuntu0.16.04.1                  
tzdata.all                              2016f-0ubuntu0.16.04                    2017c-0ubuntu0.16.04                    
ubuntu-release-upgrader-core.all        1:16.04.14                              1:16.04.12                              
udev.amd64                              229-4ubuntu7                            229-4ubuntu21.1                         
update-manager-core.all                 1:16.04.3                               1:16.04.12                              
util-linux.amd64                        2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
uuid-runtime.amd64                      2.27.1-6ubuntu3.1                       2.27.1-6ubuntu3                         
vim.amd64                               2:7.4.1689-3ubuntu1.1                   2:7.4.1689-3ubuntu1                     
vim-common.amd64                        2:7.4.1689-3ubuntu1.1                   2:7.4.1689-3ubuntu1                     
vim-runtime.all                         2:7.4.1689-3ubuntu1.1                   2:7.4.1689-3ubuntu1                     
vim-tiny.amd64                          2:7.4.1689-3ubuntu1.1                   2:7.4.1689-3ubuntu1                     
wget.amd64                              1.17.1-1ubuntu1.1                       1.17.1-1ubuntu1.3

新增软件

软件名                                  版本号
ebtables.amd64                          2.0.10.4-3.4ubuntu1                     
efibootmgr.amd64                        0.12-4                                  
ethtool.amd64                           1:4.5-1                                 
grub-efi.amd64                          2.02~beta2-36ubuntu3.17                 
grub-efi-amd64.amd64                    2.02~beta2-36ubuntu3.17                 
grub-efi-amd64-bin.amd64                2.02~beta2-36ubuntu3.17                 
lib32ncurses5.amd64                     6.0+20160213-1ubuntu1                   
lib32tinfo5.amd64                       6.0+20160213-1ubuntu1                   
libefivar0.amd64                        0.23-2                                  
linux-headers-4.4.0-119.all             4.4.0-119.143                           
linux-headers-4.4.0-119-generic.amd64   4.4.0-119.143                           
linux-headers-4.4.0-21.all              4.4.0-21.37                             
linux-headers-4.4.0-21-generic.amd64    4.4.0-21.37                             
linux-image-4.4.0-119-generic.amd64     4.4.0-119.143                           
linux-image-4.4.0-21-generic.amd64      4.4.0-21.37                             
linux-image-extra-4.4.0-119-generic.amd64 4.4.0-119.143                           
linux-image-extra-4.4.0-21-generic.amd64 4.4.0-21.37                             
lsscsi.amd64                            0.27-3                                  
rename.all                              0.20-4

删除软件

软件名                                  版本号
gcc-4.8.amd64                           4.8.5-4ubuntu2                          
gcc-4.9.amd64                           4.9.3-13ubuntu2                         
grub-gfxpayload-lists.amd64             0.7                                     
grub-pc.amd64                           2.02~beta2-36ubuntu3.1                  
grub-pc-bin.amd64                       2.02~beta2-36ubuntu3.1                  
libpython3.5.amd64                      3.5.2-2~16.01                           
linux-crashdump.amd64                   4.4.0.66.70                             
linux-headers-4.4.0-31.all              4.4.0-31.50                             
linux-headers-4.4.0-31-generic.amd64    4.4.0-31.50                             
linux-image-4.4.0-31-generic.amd64      4.4.0-31.50                             
linux-image-extra-4.4.0-31-generic.amd64 4.4.0-31.50

配置修改

1、调长rcu_cpu_stall_timeout,由60改为300。
2、去掉ssh的弱MAC和弱Ciphers,保留:
    ciphers aes128-ctr,aes192-ctr,aes256-ctr
    Macs hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-sha2-256,hmac-sha2-512
3、不自动加载nouveau驱动。在使用GPU时,防止对CUDA驱动造成干扰。